Frequently Asked Question

I want to use a newer Postgis version
Last Updated 7 months ago

First check what postgis versions are available:

postgres=> select * from pg_available_extensions WHERE name = 'postgis';
name | default_version | installed_version | comment
---------+-----------------+-------------------+------------------------------------------------------------
postgis | 3.1.4 | 3.0.2 | PostGIS geometry and geography spatial types and functions
(1 row)

If you want to use that "default_version" that gets listed, then create a new database. It will have that version of the extension. You can dump the contents of your old database and import the data into the new database.

Please Wait!

Please wait... it will take a second!